/ 雑記帳

[ Tags :: Archlinux ]

Archlinux mpd-0.20.18 install

Archlinuxは何時も最新で危険なディストリだ。
現状でアップデートするとMOZCが機能しなくなる。
QT関連パッケージには地雷があるようだ。
今はアップデートしてはいけない時期らしい。
仕方がなくバックアップでイメージをレストアしたら今度は起動しない(笑)
その原因追求に一週間?ぐらいを浪費した。
pacmanで最新のmpdをインストールするとmpdが起動しない。笑うしか無い。
それでも、それでも音が良いから?粘って動作させる。

それでmpd-0.20.18をソースインストールして弄ってみたが
このエラーが出て起動不能だった...
exception: Failed to bind to '[::]:6600'
exception: nested: Failed to bind socket: Address already in use

足りないライブラリーとかも有ったかも知れない。
(alsa関連とtag関連のパッケージで)
一応このコンフィグで動作させる事が出来た。
./configure --disable-ipv6 --with-systemdsystemunitdir=/usr/lib/systemd/system

起動もsystemctlから真っ当に出来る(笑)
$ cat /usr/lib/systemd/system/mpd.service
[Unit]
Description=Music Player Daemon
Documentation=man:mpd(1) man:mpd.conf(5)
After=network.target sound.target
      
[Service]
Type=notify
#ExecStart=/usr/local/bin/mpd --no-daemon
ExecStart=/usr/local/bin/mpd --no-daemon /etc/mpd.conf
      
# allow MPD to use real-time priority 50
LimitRTPRIO=50
LimitRTTIME=infinity
      
# disallow writing to /usr, /bin, /sbin, ...
ProtectSystem=yes
      
# more paranoid security settings
NoNewPrivileges=yes
ProtectKernelTunables=yes
ProtectControlGroups=yes
ProtectKernelModules=yes
# AF_NETLINK is required by libsmbclient, or it will exit() .. *sigh*
RestrictAddressFamilies=AF_INET AF_INET6 AF_UNIX AF_NETLINK
RestrictNamespaces=yes
      
[Install]
WantedBy=multi-user.target
Also=mpd.socket

参考リンク:https://www.reddit.com/r/linuxquestions/comments/348c0l/mpd_autostart_with_systemd/

追記:今朝もう一度起動したら動かない(笑)原因は/var/run/mpd/mpd.pidが作成されない事。
もう面倒なので

#!/bin/bash
rm /var/run/mpd/mpd.pid
echo "" > /var/run/mpd/mpd.pid
chmod 777 /var/run/mpd/mpd.pid

psn=`ps aux | grep mpd | grep bin | awk '{print $2}'`
kill $psn
echo "--------------------------------"
ps aux | grep mpd | grep bin
echo "--------------------------------"
echo ""
#/usr/local/bin/mpd /etc/mpd.conf
systemctl restart mpd
systemctl status mpd
echo "--------------------------------"
ps aux | grep mpd | grep bin
echo "--------------------------------"



— posted by at 12:30 am  

tkpacman Archlinux pacman コマンドのGUI

https://sourceforge.net/projects/tkpacman/?source=typ_redirect ダウンロード先
pacman -S tk
tar xvzf tkpacman-1.7.0.tar.gz
cd tkpacman-1.7.0.tar.gz
cp ./tkpacman /usr/bin/
mkdir /usr/share/tkpacman
cp -r -p icons /usr/share/tkpacman/
cp ./*.tcl /usr/share/tkpacman/
cp tkpacman.desktop /home/hoge/Desktop/

— posted by くま at 04:00 pm   commentComment [0] 

Archlinux DSD native 再生が通常のインストールで可能になった。

$ uname -a
Linux arch 4.8.13-1-ARCH #1 SMP PREEMPT Fri Dec 9 07:24:34 CET 2016 x86_64 GNU/Linux
      
$ /usr/bin/mpd -V
Music Player Daemon 0.20.2
      
これで何が言いたいのかと言えば
Archlinuxを普通にインストールして
この状態ならばパッチも当てずコンパイルの必要もなく
(カーネルで指定されたDDC,DACの必要はあるが)
DSD native 再生が通常のインストールで可能になったと言う事です。
もちろん/etc/mpd.confはDSDnativeに関する指定は何も指定しなくて
問題なしです。世の中進んでます!

— posted by くま at 08:42 am   commentComment [0] 

git版 mpd を使って且つ指定 DAC XMOS を使えばDSDをnativeで再生できる

$ ./mpd -V
Music Player Daemon 0.20.2 (v0.20.1-32-gc5cf66402)

$ uname -a
Linux arch 4.8.13-1-ARCH #1 SMP PREEMPT Fri Dec 9 07:24:34 CET 2016 x86_64 GNU/Linux
この組み合わせで確認できた。
DSD512再生時のalsaステイタス
--------------------------------------
カード 0: DIYINHK
access: RW_INTERLEAVED
format: DSD_U32_BE
subformat: STD
channels: 2
rate: 352800 (352800/1)
period_size: 32768
buffer_size: 131072
--------------------------------------

— posted by くま at 11:44 pm   commentComment [0] 

<< 2019.11 >>
SMTWTFS
     12
3 4 56 789
10 111213 141516
17181920212223
24252627282930
 










T: Y: ALL: Online:
ThemePanel
Created in 0.0230 sec.