/ ffmpeg mediatomb-0.12.1 コンパイル

ffmpeg mediatomb-0.12.1 コンパイル

ffmpeg-1.2.1-4.el6.x86_64
ffmpeg-compat-0.6.6-1.el6.x86_64
ffmpeg-compat-devel-0.6.6-1.el6.x86_64
ffmpeg-devel-1.2.1-4.el6.x86_64
ffmpeg-libs-1.2.1-4.el6.x86_64
ffmpeg-spice-libs-0.4.9-0.15.5spice.20080908.el6.x86_64
ffmpegthumbnailer-2.0.8-1.x86_64
gstreamer-ffmpeg-0.10.11-1.el6.rf.x86_64
この環境でmediatomb-0.12.1をコンパイルするとエラーになる。
パッチを当てないとダメ。
      
avformat/avformat.h:1689)
../src/metadata/ffmpeg_handler.cc:279: 警告: ‘void
av_close_input_file(AVFormatContext*)’ is deprecated (declared at /usr/include/ffmpeg/libavformat/avformat.h:1689)
make[2]: *** [libmediatomb_a-ffmpeg_handler.o] エラー 1
make[2]: ディレクトリ `/home/kkuma/mediatomb-0.12.1/build' から出ます
make[1]: *** [all-recursive] エラー 1
make[1]: ディレクトリ `/home/kkuma/mediatomb-0.12.1' から出ます
make: *** [all] エラー 2

参考リンク:http://kkuma.mydns.jp/Linux-media-server/index8.shtml

— posted by くま at 12:11 pm   commentComment [0]  pingTrackBack [0]

この記事に対する TrackBack URL:


コメントをどうぞ。 名前(ペンネーム)は必須で、ウェブサイトURLはオプションです。

ウェブサイト (U):

タグは使えません。http://・・・ は自動的にリンク表示となります

:) :D 8-) ;-) :P :E :o :( (TT) ):T (--) (++!) ?;w) (-o-) (**!) ;v) f(--; :B l_P~ (QQ)

     

[Top ↑]

<< 2014.10 >>
SMTWTFS
   1234
5678910 11
12131415161718
19 202122232425
262728293031 
 










T: Y: ALL: Online:
ThemePanel
Created in 0.0213 sec.